Firmware settings, first prints, slicer settings...

Discussion in 'OpenBeam Kossel Reprap and OpenBeam Kossel Pro' started by Terence Tam, Dec 27, 2014.

  1. Def

    Def Member

    Tried it with my other laptop (dual core AMD). Same issue, stopped about 3-4 mins into a 6.5 min print (MatterControl default calibration cube). All default settings except 4 skirt loops to prime the nozzle and having no G29 offset.

    This time I did get a MatterControl error message. Under the printer it is connected to it says, "Connection Lost. A device attached to the system is not functioning."


    The BW Pro board never disconnected according to Device Manager, and Windows still reports it as working properly.

    I'm using MatterControl 1.2.2, which is the latest version. And updated the BW Pro FW to the mid Jan release in the first post of this thread.

    I have a Belkin Gold cable coming (be here Friday). Cheapest cable that didn't look like crap at Best Buy was $30. No thanks! I'll wait a day for that price.


    My mini-prints are looking great though with default settings. :)
  2. Def

    Def Member

    Also, the RED status LED on the BW Pro (furthest to the right) goes out completely when the printer freezes. The green power LED stays lit the entire time.


    If I power cycle the printer and restart MC, it connects right back up. Red status LED seems to flash a bit when it's just connected and not doing anything. Not sure what normal behavior is here, just giving details.
  3. AndyG

    AndyG Member

    Seems like you are able to recreate better than I could when I was having the issue. If you have time before friday maybe you can try one of these guys:

    http://www.thingiverse.com/thing:640254

    I'm using one now with a better quality USB cable and a set of vibration dampners and I've been printing from PC for probably a good 6-8 hours now without issue.
  4. Def

    Def Member

    I can only get a couple of minutes into a print max, so I can't even make stuff. The USB cable is not being pulled at an angle though (one of the first things I checked).

    Terence has a replacement BW Pro board being sent, and I've got a Belkin Gold usb cable coming (supposedly double shielded, thicker wires, and the audio DAC guys like them).

    I have Astrosyn vibration dampers on my KP as well. I didn't do one on the extruder, but I do have some cheaper cork ones that I might put on the extruder if I get some time. Vibration isn't bad at all with the astrosyn dampers on the vertex motors.
  5. David Boyd

    David Boyd Active Member

    Just a quick data point. I use RepetierHost and have not seen any such lockups and not pauses outside of normal. In addition, I use a cheap USB cable and a USB extension to go from the laptop to the Kossel. You might try RepetierHost or Pronterface and see if you get the same behavior - it will help isolate it
    to being a software or hardware issue. FYI - I am running @PJR latest delta-dev branch firmware.

    Picture of the 200mm vase I printed over the weekend. 16+ hours. 0.2mm layer height.

    Still a bit of tuning to do in order to eliminate threading and some blobs (likely need to just up retraction slightly).
    Getting consistent G29 values but as I posted in another thread G30 results have wide variance and my adjustments (endstops, delta radius, etc.) are very
    large. Still trying to chase that down. Also, have to get the probe standoff to seat correctly and stay tight each time. Lastly, need to work on tuning
    speed had to print this one pretty slow or I end up with air prints.

    Attached Files:

    • vase.pdf
      File size:
      338.9 KB
      Views:
      24
    Rick Gordon likes this.
  6. Def

    Def Member

    Great advice! As it turns out, MatterControl was the issue. With the same Amazon Basics cable, laptop, driver etc. and RepetierHost, I just successfully printed a 20 mm calibration cube (same ~19.9 x 19.7 mm x/y dimensions, a little over on the height, about 20.5-20.6 mm). Also printed for about 45 mins straight until my filament got jammed up and snapped on the rook I was trying to do.

    Haven't had one crash with RepetierHost (using Slic3r to slice).

    Since some other people had crashes with MatterControl as well, I'm guessing it has a communication bug, or causes BW Pro to lock up.


    Anyway, I wish MatterControl worked better, as the user interface was pretty easy. But RepetierHost isn't that difficult to use really...


    So looks like mystery solved. Thanks for the help guys.


    Terence,

    Let me know if you'd still like my BW Pro back. I'll swap them out and test with MatterControl to see what the deal is, but it definitely seems to be a software issue right now.
  7. Terence Tam

    Terence Tam Mr. OpenBeam Staff Member Vendor

    Looping in @Taylor and @Lars Brubaker ...

    We'd like to get the code that was crashing the code, and yes, we'd still would like the card and cable. It's not urgent, since we've already dispatched you your replacement and it's already running, but we'd like to be able to replicate the issue just the same.

    Thanks for all your help.

    -=- Terence
  8. Def

    Def Member

    Just printed a solid 7 hrs with Rep.Host, never once had an issue with the hardware (just my n00bness).

    Got the replacement BW Pro. I'll try to swap it out this weekend and see the results.

    Gotta put the track car back together as well, so hopefully the BW swap can happen. Texas World Speedway event next weekend. :)
  9. NickF

    NickF New Member

    Does anyone have a good working Repetier config I can use?
  10. ted35

    ted35 New Member

    Enclosed are my Slic3r settings...these have been working very well for me so far. YMMV

    Attached Files:

  11. Carl Quinn

    Carl Quinn New Member

    What version of slic3r are you using @ted35 ? My config looks similar to yours, but I am pushing my printer faster with mixed results. Maybe I'll try slowing mine down a bit to see if it is more reliable.
  12. ted35

    ted35 New Member

    @Carl Quinn. Yeah, any faster than 30 mm/sec and my prints suffer. It seems to be the sweet spot. Cheap filament doesn't help either. I'm away from my computer at the moment...so I'm not sure what version of slic3r I'm using.
  13. Rick Gordon

    Rick Gordon Member

    I thought I finally had things dialed in - using MCP - although I still had problems with cooling taller prints. But after yesterday, I'm starting to wonder.
    I had already made one print of a fan bracket clamp (to try and help with cooling), and was starting another. I cloned and started printing two-up. It got about 20% done when suddenly I started getting this rather sparse layers. I let it finish. It kind of looks like foam - the layers are quite sparse and have holes.
    Subsequent attempts at the same layer height (0.2mm) yielded same results. Tried dropping to 1.5mm, and that started to look okay - but at halfway done the print broke free of the glass. (precleaned before print.) I applied some hairspray, started again, and it broke free a few layers above the previous attempt.
    Again, I printed one of the same objects the week before. I double-checked filament width, it was okay. I double-checked the extruder - it was clean and feeding well.
    No time today to work on it - but am puzzled why it suddenly went awry.
  14. ted35

    ted35 New Member

    Hmmmm. Sounds like maybe an intermittent clog. I've had to deal with that myself. Everything works well...until it doesn't.
  15. Rick Gordon

    Rick Gordon Member

    how do you tell if its a clog? how can it clog intermittently? how to you repair?
    (and why would it print 0.15mm fine for awhile?)
  16. Rick Gordon

    Rick Gordon Member

    how does one decode that settings file? When I open the .zip I get a .cpgz. When I open that I get another .zip. and opening that another .cpgz. finally gave up.
  17. ted35

    ted35 New Member

    @Rick Gordon try renaming the file to .rar . I had to use WinRAR to compress the file and rename it to .zip so it would upload. See if that make any difference. If not let me know and I'll redo it. [EDIT ...attached is the correctly .zip-ped up file.]

    Also, to check for a partial clog I extrude a bit through the hotend and watch how it exits. If it falls straight down then there are no clogs....if it seems to curl to one direction or another then I believe it has an obstruction partially obscuring the exit hole. What prompted me to start checking was during a print where there was a large, flat 100% infil portion being printed everything would be fine for the first X seconds...then the material extruded would decrease for another variable amount of time then print ok again. I read in another forum how debris might float out of the way for awhile then be pushed down to block the extrusion then float up again. This seemed to describe my problem so I did a couple of "cold pulls" at 180°c (I'm too lazy to figure out how to bypass the temperature safety). So far that seems to do the trick. Hope this helps.

    Attached Files:

    Last edited: Mar 9, 2015
  18. RicerX1

    RicerX1 New Member

    When using matter control and default start gcode. After auto leveling it brings the print head at 100mm above center of the bed and heats up the hot end. The hot end ends up oozing while its heating up. Then it drops the hotend straight down to the center leaving the previous ooze right into the center of the print area then moves to start printing the skirt.

    I have modified my start.gcode in matter control to park the heat on the bottom right corner while heating followed by priming the nozzle with an anchor blob, then a short quick wipe.
    Some of these varibles only work if your using slic3r as the slicer in matter control. using other slicing engines you may want to sub variables for actual values.

    G28 ; home all axis
    G29 z-0.15 ; auto level bed
    G90 ;set absolute coordinates
    G1 X80 Y-80 F7800 ;move to front right corner
    G1 Z[first_layer_height] F7800 ;move platform close to nozzle
    M109 S[first_layer_temperature] ;(set extruder temperature)
    ;G4 P120000 ; wait another 120 seconds for nozzle length to stabilize if you are having extruder skip during the begining of prints try this out
    G92 E0; reset extrusion distance
    G1 E10; Anchor
    G1 X90 Y-70 F7800 ;wipe
  19. chadman

    chadman Member

    I moved the parked position away from the center of the print too, and found it results in a much more satisfying experience.

    Here's another idea for someone with time:
    There has been chatter on the forum concerning distaste for how the probe arm slams into the switch. Could a soft catch mechanism be designed and attached to the front left side, which would stop the probe prior to contact with the switch? The end effector could then be slowly raised to lower the arm onto the switch. This would save the switch and likely alleviate loosening of the probe arm. I realize it has been suggested that bed probing may be obsolete after calibration, but in some situations where conditions of the bed change often, that may not be the case. I'd be interested in some form of the proposed idea, if someone gets to it before I do.
  20. Rick Gordon

    Rick Gordon Member

    Thanks for the info. Not sure whether its a clogged extruder or what, hopefully that's all. I'm presuming by "cold pull" you mean you heated to 180C and then pushed the filament by hand?
    or ???

Share This Page