First print how to add g29 offset to matter control?

Discussion in 'OpenBeam Kossel Reprap and OpenBeam Kossel Pro' started by Matt, Aug 17, 2016.

  1. Matt

    Matt New Member

    So i have finally gotten around to finishing my printer, using matter control I have checked motion on everything and is all good. G29 runs fine.... but then when it goes to print it crashes into the bed. I have calculated using the .1mm move function an offset of 7.8mm between the bed probe and the hot end, how do i add this offset in mattercontrol? or is this something that has to be directly updated to the firmware eeprom?

    Sorry if this has been answered a million times, a quick search didnt turn up what i'm looking for, and the dozuki article for it just glosses over this step.
  2. Matt

    Matt New Member

    so i did g29z7.8 and g1z0 and got exactly what i want

    looking at the gcode generated by mattercontrol gives me g29z-0.1 which is crap, setup for the FSR? i'm guessing? so my current workaround is manually editing the gcode and the printing that way, would be nice if they let you pick that kind of stuff in the options? or am i just missing it? hopefully i will have a hips benchy to show off in a few hours.
  3. protoserge

    protoserge Member

    I can't determine if you fixed your issue, but what is your printer build volume height in MatterControl? If it is set too high, the printer will drive the end effector into the bed.
  4. Taylor

    Taylor Moderator Staff Member

    The Z offset in MatterControl is under Settings > Printer > Print Area
  5. Matt

    Matt New Member

    figured it out, had to enable 'advanced' mode to be able to edit it

Share This Page