If you have "Cannot Connect" to printer in MatterControl

Discussion in 'OpenBeam Kossel Reprap and OpenBeam Kossel Pro' started by Mike Ziomkowski, Jan 13, 2015.

  1. Mike Ziomkowski

    Mike Ziomkowski Administrator Staff Member Vendor

    Hey all,

    I found that there is potential issue how drivers install in MatterControl for Kossel Pro. If you go through the normal install driver in MatterControl then find that you still cannot connect to printer it is possible that printer did not enumerate properly during driver install. I found that during step 3 (when you connect powered printer) if you do not wait long enough for printer to enumerate before clicking next, driver install will fail. Try this:

    1) In the printer list chose to remove the printer
    2) Add the printer again to prompt going through driver setup again
    3) When it asks you to connect printer (Step 3) connect the printer, but wait at least 10 sec before clicking next

    This worked for me during a test, might help you too.

    -Z
  2. Rohan

    Rohan New Member

    I found it helps if you keep device manager open and make sure you see the printer there prior to telling MatterControl that it's connected.
  3. Sudip Phuyal

    Sudip Phuyal New Member

    I got waring sign at BrainWave (hadrware) in Device Manager list in windows. I want to know how this problem gets resolved. I have tried with 64 bit win 8.1 and 32 bit win 7 also. I get device driver is not sucessfully installed warning.. so what should I install for my PC to Show my Kossel Proin printer selection list. I want all softwares that would help me to make a first 3D print. :) Thanks in Advance :D
  4. Mike Ziomkowski

    Mike Ziomkowski Administrator Staff Member Vendor

    Are you using MatterControl? Did you go through the driver install that MatterControl steps you through?
  5. protoserge

    protoserge Member

    If I power off the printer, I will have to go through a full combination of USB unplugs and closing Matter Control before I can get it back up. It's not a big deal, but it can get annoying. I'm not sure if this is a good data point.

    I manually installed the driver, but MC isn't set up for the Kossel Pro by the released build yet.
  6. Bruce Segal

    Bruce Segal New Member

    The MatterControl people posted a recent build here:
    I've been building the dev branch and it seems to be getting there. More KosselPro support every day.
  7. TimothyT

    TimothyT New Member

    My experience is that MatterControl seems a bit buggy. I often have problems with MatterControl releasing COM3. I end up needing to restart Windows to get MC to talk with the printer.

    What has seemed strange to me however is that pushing the reset on the Brainwave Pro doesn't always seem to reboot it. Or in some cases behave as I would have expected, This was all a while ago... so there could have been other factors too...

    73,
    Timothy
  8. Dave

    Dave Member

    Updated Matter Control and cant connect to the printer. Com3 Reports Model= Brainwave, Category= Unknown. I have gone through the install process in MatterControl, I have restarted windows after installed the driver and still it just hangs there saying "Connecting..." My printer was down for a month while waiting for parts to be replaced and when I started the software back up it tells me there is an update, I update and now I cannot connect no matter what I do. I am running windows 7 64bit

    I tried everything listed in this thread and still nothing.
  9. Def

    Def Member

    I'm also having issues getting the driver installed via MatterControl. I'm on Win7 Home 64 bit.

    I've tried all manner of rebooting the computer, cycling power on Kossel Pro, uninstalling driver etc. It consistently runs into a problem on driver install in Windows. MatterControl then reports it cannot see any printers.


    Some people have said they've manually installed drivers - where is the file for that? Everything in this forum is scattered across dozens of pages, and the search function seems spotty at best.

    It'd be great if we could get a wiki up and going like was mentioned by someone else.
  10. Randy Merrill

    Randy Merrill New Member

    For reference for those that use Linux (specifically Ubuntu) to connect to the Kossel Pro. I couldn't connect with MatterControl. After trying several different things (ex: update the firmware) I was prompted by Arduino to add my user to the dialout group to get it to be able to talk to the printer over USB. I am new to the 3d printer world, so I wasn't expecting this and nothing in MatterControl seemed to suggest it.
  11. Greg

    Greg New Member

    Running Windows 7 32 bit, I couldn't get MatterControl to connect using the start up feature either. I did locate the Brainwave board within device manager and noticed the "exclamation mark" icon. I then reinstalled the serial driver from within device manager by selecting to search for it under the MatterControl installation directory on the PC. It located it as a "serial driver". I let this run and it connected OK.
  12. roadblock

    roadblock Member

    I keep getting a com 3 in use error, disconnect/reconnect usb wire 20-30 times and was able to connect to it once...
  13. protoserge

    protoserge Member

    Did you close MatterControl in between attempts? Is the device (Brainwave) showing up in device manager?
  14. roadblock

    roadblock Member

    I finally figure out what happened. It was the repetier host server being active which I had forgotten I had it on. I just disabled it and was able to connect with Matter Control again. One thing I can't blame the KP for...

Share This Page