IMPORTANT - Probe retraction issue on shipment #1

Discussion in 'OpenBeam Kossel Reprap and OpenBeam Kossel Pro' started by Terence Tam, Dec 25, 2014.

  1. Terence Tam

    Terence Tam Mr. OpenBeam Staff Member Vendor

    We made a mistake on the firmware on the first shipment of printers.

    When we were testing the firmware built, we tested it on our first prototype which had a 50mm spacing on the top for the end stop switches. After KS-001, we changed this to 60mm for two reasons: 1) the extra 10mm space made it easier to wire the end stop switches, and most importantly, everyone's kit shipped with a 60mm spacer - the leg of the upper triangle vertex.

    However, when we moved those end stop switches, the entire coordinate system of the printer shifted down by 10mm, and therefore the probe overtravels on the retraction sequence, causing the drive system to loose steps.

    We realized what was going on when the first initial feedback came back on the forum, and we fixed it on all the printers that were shipped in the most recent shipment. (As an aside, this is why you invest in good tooling and fixturing; Mike was able to test and reprogram 100 additional boards very quickly due to our panini press fixture. It was considered to be better than opening up 100 sealed controller cards and reprogramming and resealing them. Those boards will go onto Amazon when we are back from vacation).

    If you have a printer that was in the original shipment, you likely will need to adjust the firmware setting in configuration.h on the firmware. I don't have the firmware handly; I'm on my wife's laptop now, it's 6am where I am and our next flight leaves in 3 hrs, but I will do more project documentation and firmware / code release when I get to my final destination.

    If for some reason people can't flash their firmware; we promised a plug and play printer, and we'll cross ship boards if necessary to make that happen. But we'd like to work with people on flashing their firmware first.
  2. AndyG

    AndyG Member

    Glad to hear you've got a fix! Definitely thought this was firmware related when I encountered the issue tonight printing for the first time.
  3. protoserge

    protoserge Member

    That explains so much! I was afraid to touch the printer after just trying to move X and Y while at the Z_max would bind up the axes and force a quick power off.

    I'm plenty confident in installing firmware - I just don't have a handy reference for the modifications. I'll look at it tomorrow. Is configuration.h the same as the firmware config "matrix" in MatterControl?

    I also have some troubleshooting to see if something is up with my extruder - I don't notice any turns when doing tests on my extruder in MatterControl. I'll try first getting the Brainwave driver from Github (I will have to dig up a link though). I'll also try swapping motors with the Y-axis to see if it drives.
  4. degreaser

    degreaser Member

    Hi Terence - Could you list the KS#s affected by this?
  5. protoserge

    protoserge Member

    If you have your printer already, you are likely in that group.
  6. protoserge

    protoserge Member

    For some reason pressing the extrude (E+) button is the same as a Z+ operation. Any ideas?

    I know the extrude stepper works. I put the y-axis cable onto it and jogged it. I know I have one of the "50mm firmwares".
  7. Terence Tam

    Terence Tam Mr. OpenBeam Staff Member Vendor

    Did you home it first? If you have not, E+ triggers a homing operation.
  8. protoserge

    protoserge Member

    I believe that is the case. I have tried homing and then using extrude, but I'm still unable to get any response. I'll try swapping a cable on the Brainwave side.

    By the way, I did install the Braindwave.inf driver from the Github.

    I also just saw you posted a lengthy post on Firmware settings. I'll head over there and see if I can get the firmware updated.

    OH. I forgot to mention... When it was homed, it continued to drive the axes. It was likely stalling all three carriage motors and I power cycled. It was not an isolated case and I was able to repeat it. I don't know if there is some other issue.
    Last edited: Dec 27, 2014
  9. protoserge

    protoserge Member

    OK it looks like problem might be solved due to some interlock features in the software I wasn't aware of ;)

    <-echo: cold extrusion prevented

    Terence, 24V is wonderful. This thing heats up so quickly.
  10. Dave

    Dave Member

    So after the probe is done calibrating the bed we have to manually push it up to retract it so it doesnt interfere with printing? Just want to make sure I understand how the probe and sequence of events for printing.

    Also i have not changed my Firmware as I would prefer to wait for MatterControl/Openbeam to provide that with instructions on Flashing it properly etc...

    Thanks
  11. Dr.J

    Dr.J New Member

    I am unclear as well as to the indented functioning of the probe.

    Should I expect it to auto deploy at the beginning of a print to run a G29 sequence?
    Should I expect it to auto retract when completed?
    Or will I need to do both of these steps manually?
  12. Chris

    Chris Member

    @Dr.J Once your firmware is up to date, you need to run G28 (home) first and then a G29 should successfully do the bed probe, which will autodeploy the probe, test the bed, and then push the probe back up into its locked position. The first time you do this, you'll want to watch closely -- I actually had to extend the screw on my probe's standoff a small amount for it to catch on the arm, which I believe at least some others haven't needed to do (see attached photo).

    As per the other threads, do *not* then start to print unless you've also manually fixed the firmware to account for the 10mm change in design. I believe someone will be posting an updated firmware today or tomorrow with this fix, and any others that we run into in early testing.

    Attached Files:

  13. shchua

    shchua Member

    My KP (KS-032) homes (G28) fine, deploys the probe on G29 but then probes about 10 cm above the glass. It probes all position in mid-air, touches the ZY bed clamp and retracts the probe just fine.

    Any clues why my printer probes in mid-air instead of touching the glass. I am using Repetier Host V1.0.6.
  14. grainiac

    grainiac Active Member

  15. Chris

    Chris Member

    It should be homing on the XY clamp (the one above the extruder motor).

    As for the rest, check out @graniac's answer and play around with M119 to check the status of all of your switches.
  16. shchua

    shchua Member

    Indeed, the screw holding the standoff came loose and the microswitch was being pressed. Auto-level works fine after I added a dab of threadlocker and tightened the screw !

    BTW, anyone noticed that one of the end effector bearings on the X axis brushing against the X belt as the end effector is being clocked to deploy the probe ? I don't think any damage is being done as it's plastic to plastic contact, but it would be nice if the path could be changed to avoid the brushing.
    protoserge likes this.
  17. shchua

    shchua Member

    Thank Chris and grainiac. The cause was the loose standoff on the probe. Auto levelling looks good now. There's no dragging during auto levelling. It looks like my printer shipped with the FW that was fixed to use 60 mm offset for the end stops.

    And you're right - the probe homes on the XY clamp to retract.
  18. Chris

    Chris Member

    I have. I also notice that it brushes the XY bed clamp ever so slightly before it starts probing. I'm sure someone will fix it once the next version of the code is posted. Also working on the Z offset issues -- it seems that there are at least 2 of us with .5-.7mm difference (and I'm having a HORRIBLE time getting my PLA to stick to anything) there are still some fine-tune changes needed to match the firmware up to the final version of the build instructions.
    protoserge likes this.
  19. shchua

    shchua Member

    PLA sticks fine to 3M blue painters tape, at least on my Ultimaker at work.
  20. Chris

    Chris Member

    Yeah, I have some Natural PLA that works fine but I can't get Silver or Green Pro (all 3 from matterhackers) to stick consistently to tape or straight on the glass. I have plenty of other colors to test with but something is definitely up with my config and I'm fine waiting until the Z offset stuff is fixed so I can at least remove that variable from the equation of temp/bedtemp/speed, etc.

Share This Page