New Firmware causes incorrect Auto-bed Leveling

Discussion in 'OpenBeam Kossel Reprap and OpenBeam Kossel Pro' started by Khom Kaowthumrong, Sep 6, 2016.

  1. Khom Kaowthumrong

    Khom Kaowthumrong New Member

    Hi, I am new to the forum. I just put my Kossel Pro together this weekend. Nice little piece of hardware. I got some good prints out but was running into some print hangs, where the printer would just stop mid print. I thought that a new firmware update might help and notice that there was one posted here. I installed the new firmware and now the bed-leveling is off. It causes the prints to go haywire. If I disable the bed leveling in Matter Control, it seems to print fine. With it enabled, the bed seems to be calibrated at a tilt with some setting off.

    Has any run into this problem after the latest firmware update? Any help would be appreciated.
  2. protoserge

    protoserge Member

    Can you elaborate? Is the printer extruding mid-air? Does it seem to comolete the autolevel correctly or does it seem to retract in the air? What is your printer build volume set at?
  3. Khom Kaowthumrong

    Khom Kaowthumrong New Member

    The printer, once the G29 Z0.1 is run tries to extrude at an angle. I tried printing a calibration cube and would see one corner of the cube be on the surface while the other 2-3 corners be a good 8-9mm off the platform. The autolevel does appear to finish correctly. I looked in the console and see that there are values being returned. I will post the output from the console along with the build volume setting tonight.
  4. protoserge

    protoserge Member

    Does it print properly without incurring a G29? If it does, something with G29 has to be causing the issue.
  5. Khom Kaowthumrong

    Khom Kaowthumrong New Member

    Thanks all for the help. I just figured out the cause of the mid air extrusion. After walking through the starting block of the G-code, it seems that once the new firmware was installed, the z offset became drastically different from before. I am still not sure why quite yet but that will be another investigation that I will have to do. The culprit here is the squirt and wipe routine that is on by default in MatterControl. This had the position of the extruder in a bad location well below the build platform. As it tried to wipe the excess filament off it would hit the platform hard enough to jostle the location placement of at least 2 towers. I looked at the output console and confirmed that the system lost track of it location and thought that it was in fact lower that it actually was. Hence the floating extrusion. Once I corrected the offset in the wipe routine and z offset things seem to be behaving a little better now. I am still amazed that the offset would change from one firmware to another by over 10mm.
  6. protoserge

    protoserge Member

    Yeah that squirt and wipe led me to believe my printer went berserk. Thankfully we got it straightened out in another thread. You're not the third this has happened to.
    Last edited: Sep 7, 2016
  7. Joseph Tam

    Joseph Tam New Member

    where is the fix for this issue?

    thanks

    -joe
  8. protoserge

    protoserge Member

    It is in MatterControl in the custom code for pre-printing.
  9. Khom Kaowthumrong

    Khom Kaowthumrong New Member

    I just removed the squirt and wipe section in the custom G-code section of mattercontrol.

Share This Page